Feedback zu 12v/400v Boost-Converter

Für Netzteile, NF-/HF-Verstärker, Reparaturen und allgemeine Elektronikprojekte.

Moderatoren: ebastler, SeriousD, MaxZ

Nachricht
Autor
Benutzeravatar

Thread-Ersteller
skudo
Beiträge: 63
Registriert: Sa 10. Sep 2016, 09:27
Schule/Uni/Arbeit: Hobbyelektroniker
Hat sich bedankt: 6 Mal

Re: Feedback zu 12v/400v Boost-Converter

#16 Beitrag von skudo »

@Thunderbolt Könnte gut sein, dass es daran liegt. Ich messe auf diesem weg ähnliche Spannungsspitzen, jedoch viiiiel schwächer als wenn ich direkt messe (mit 10x probe sehe ich gar nichts, mit 1x probe dann aber ein wenig).

@Count-Doku Das mit der Diode habe ich auch schon versucht, hat nicht wirklich was verändert, scheint wirklich nur eine falschmessung gewesen zu sein. Tut mir leid, dass ich aufgrund dieser Dummheit deine Zeit etwas verschwendet habe :/
Das mit dem NE555 werde ich mal versuchen, gibt mir definitiv mehr Flexibilität als momentan...
Ich habe vor einen Flip-Flop oder Latch zu verwenden um den Converter an/aus zu schalten. Er sollte automatisch aus sein beim Einschalten und über einen Taster kann er aktiviert werden und sollte dann wenn die 400v erreicht sind den Flipflop automatisch zurücksetzten. Ich brauche eben neben dem normalen Steuersignal auch das Invertierte für die Status-LED's.

EDIT: Soeben gab es ein riesiges Problem: aus irgendeinem Grund ist die UF4007 kaputt gegangen (kurzschluss in beide Richtungen) und deswgen hat sich der Elko (bei 250v) über den Mosfet entladen und dabei ein Kabel in die Luft gejagt :/ . Wieso denn das? Ich dachte diese Diode kann 700V Vrms aushalten?!
Jake is dead because Jake eats lead.

Benutzeravatar

Count-Doku
Beiträge: 442
Registriert: Mi 26. Jun 2013, 15:44
Schule/Uni/Arbeit: IST-Student (TUBS)
Hat sich bedankt: 29 Mal
Danksagung erhalten: 57 Mal

Re: Feedback zu 12v/400v Boost-Converter

#17 Beitrag von Count-Doku »

Ich würde definitiv mal den Kondensator am Ausgang kleiner machen. Vielleicht erstmal mit ein paar µF testet, dass du dort eine stabile Hochspannung hinkriegst. Dann den großen Kondensator hinter den Glättungskondensator über einen Widerstand anschließen. Sonst könnte es a) schwierig werden die hohe Spannung zu erreichen und b) sehr lange Anschaltzeiten mit entsprechend starken Transienten (hohe Spannung & viel Strom) geben, die dir deine Diode killen. Versuch es doch mal so:
Unbenannt.png
Den Widerstand musst du experimentell ermitteln, kannst ja auch gegen Ende des Ladevorganges überbrücken, wenn du die maximale Spannung rausholen willst.

Oder du benutzt direkt eine Schaltung die Kurzschlussfest ist. (Denn so sieht dieser sehr große Kondensator für den Step Up Wandler am Anfang aus...)

Benutzeravatar

Thread-Ersteller
skudo
Beiträge: 63
Registriert: Sa 10. Sep 2016, 09:27
Schule/Uni/Arbeit: Hobbyelektroniker
Hat sich bedankt: 6 Mal

Re: Feedback zu 12v/400v Boost-Converter

#18 Beitrag von skudo »

Vielen Dank @Count-Doku!
Diese Herangehensweise gefällt mir sehr. Für den Elko werde ich sehr wahrscheinlich einen Lastwiderstand verwenden und ich habe nur 1K 50W Widerstände hier. Muss wohl genügen aber bei 400V sollten 1K Ohm passend sein :)
Leider hat diese defekte Diode nicht nur den MOSFET frittiert sondern auchnoch gleich den MOSFET-Driver IC, heute ist echt nicht so mein Tag ^^
Jake is dead because Jake eats lead.

Benutzeravatar

Count-Doku
Beiträge: 442
Registriert: Mi 26. Jun 2013, 15:44
Schule/Uni/Arbeit: IST-Student (TUBS)
Hat sich bedankt: 29 Mal
Danksagung erhalten: 57 Mal

Re: Feedback zu 12v/400v Boost-Converter

#19 Beitrag von Count-Doku »

Wenn deine Frequenzen eher niedrig sind und du wirklich einen NE555 (bipolar Variante) hast, kannst du auch direkt mit dem NE555 den Mosfet treiben. Musst halt den NE555 dann auch mit 12V versorgen.

Außerdem solltest du nochmal über den IRF1404 nachdenken, ich denke die VDSS von 40V könnte etwas niedrig sein, und die Id von 202A brauchst du sicher nicht. Dann vielleicht lieber einen Mosfet mit mehr VDSS und weniger Id nehmen, die haben auch meiste eine niedrigere Gatecharge.

Benutzeravatar

Thread-Ersteller
skudo
Beiträge: 63
Registriert: Sa 10. Sep 2016, 09:27
Schule/Uni/Arbeit: Hobbyelektroniker
Hat sich bedankt: 6 Mal

Re: Feedback zu 12v/400v Boost-Converter

#20 Beitrag von skudo »

Also eig. habe ich nicht den NE555 sondern den TLC555CV, daher der MOSFET-Driver. Den IRF1404 brauch ich noch für andere Projekte welche nichts mit dem Converter zu tun haben, daher kann es nicht schaden ihn wenigstens dafür auszutesten. Grundsätzlich dachte ich aufgrund des sehr tiefen RDS(on), dass der evtl. noch ganz brauchbar sein könnte. Für was bräuchte der denn mehr als 40V VDSS im converter? Da werden mit peaks max. 20v anliegen denke ich mal... Eine höhere Gatecharge sollte bei dem Treiber (13A max.) denke ich nicht ein allzu grosses Problem darstellen.
Jake is dead because Jake eats lead.

Benutzeravatar

Count-Doku
Beiträge: 442
Registriert: Mi 26. Jun 2013, 15:44
Schule/Uni/Arbeit: IST-Student (TUBS)
Hat sich bedankt: 29 Mal
Danksagung erhalten: 57 Mal

Re: Feedback zu 12v/400v Boost-Converter

#21 Beitrag von Count-Doku »

Da werden mit Peaks über 400V anliegen. Dein Boost Converter funktioniert ja so, dass du während der MOSFET On-Time die Spule kurzschließt, dadurch fließt dort ein hoher Strom und es baut sich ein starkes Magnetfeld auf. Wenn dann der MOSFET aufgeht, gibt es eine Selbstinduktionsspitze (weil die Spule den Strom aufrechterhalten will) mit sehr hohem dV/dt (Spannungsanstieg). Sobald dann die Diode leitet, lädt sich der Kondensator auf. Das wiederholt sich dann ständig. Dabei geht deine Diode ja immer etwas später auf, genaugenommen immer dann wenn die Induktionsspitze min. ca 0.6V über dem Kondensator erreicht hat. Das heißt gegen Ende, siehst du vor der Diode eher etwas höhere Spannungen als am Kondensator... Ich habe durchaus an dem MOSFET Drain-Source Spannungen von 600V messen können (bei 400V eingestellter Spannung am Ausgang).
(für die genaue Funktionsweise: https://de.wikipedia.org/wiki/Aufwärtswandler )

Hier mal eine LT Spice Simulation von einer solchen Boost Schaltung. Blau ist MOSFET D-S Strecke und Grün über dem Ausgangskondensator.
Dateianhänge
Unbenannt.png

Benutzeravatar

Thread-Ersteller
skudo
Beiträge: 63
Registriert: Sa 10. Sep 2016, 09:27
Schule/Uni/Arbeit: Hobbyelektroniker
Hat sich bedankt: 6 Mal

Re: Feedback zu 12v/400v Boost-Converter

#22 Beitrag von skudo »

Oh das hab ich gar nicht berücksichtigt :/ Danke für die Erklärung.
Da muss dann wohl ein anderer MOSFET ran.

Da ich momentan noch ein paar IRFP460 rumliegen habe, werde ich mal die verwenden. Mit RDS(on) von ~0.25Ohm etwas hoch sollte bei 3A so max. 90-100°C erreichen und mit KK lässt sich das schon noch minimieren. Hat wenigstens einen VDS von 500.
Jake is dead because Jake eats lead.

Antworten