Reparatur: Yamaha M-50 Endstufe

Für Netzteile, NF-/HF-Verstärker, Reparaturen und allgemeine Elektronikprojekte.

Moderatoren: ebastler, SeriousD, MaxZ

Antworten
Nachricht
Autor
Benutzeravatar

Thread-Ersteller
gamerpaddy
Beiträge: 2369
Registriert: Mo 13. Aug 2012, 09:03
Spezialgebiet: Spezialgebiet
Schule/Uni/Arbeit: Schule/Uni/Arbeit
Wohnort: Mannheim
Hat sich bedankt: 22 Mal
Danksagung erhalten: 188 Mal
Kontaktdaten:

Reparatur: Yamaha M-50 Endstufe

#1 Beitrag von gamerpaddy »

Erst wollte ich garnicht darüber berichten, aber jetzt nachdem ich mehrere Stunden reingesteckt habe und endlich die fehler fand, tue ich es doch.

Kürzlich kaufte ich eine defekte Yamaha M-50 Endstufe, super teil, ne menge leistung und ein aktiven entzerrer für noch weniger THD über den gesamten leistungsbereich.
https://www.hifi-wiki.de/index.php/Yamaha_M-50

Bekommen hatte ich diese für ca 40..50€, dabei gehen die für viel mehr über die theke.. wo war der haken?
Es fehlten teile und darin hat jemand ordentlich rumgepfuscht. Der Gehäusedeckel fehlte und man fand überall Lötarbeiten die von einem Klempner hätten seien können.

Nagut, 1000 teile puzzle mal wieder, ich hab ja zeit.

Als das teil dann ankam maß ich sofort die Endstufentransistoren durch, dabei fiel mir auf dass der rechte Kanal auf der Low-side ein Kurzschluss hatte, die Hauptsicherung durch war, die Emitterwiderstände durch waren und auf dem linken kanal die Collector seite der Low-side niederohmig zum Kühlkörper war..
Hätte nur noch gefehlt dass es darin gebrannt hätte, immerhin gab es bis heute eine rückrufaktion von yamaha für genau diese serie.. Wieso? RIFA Kondensatoren die feuer fingen :D

Also ab auch reichelt. Ich hab einfach jeden Transistor bestellt der in der Endstufen-teil war, sind ja centartikel und nicht haben, brauchen und erneut bestellen ist teuerer als haben aber vielleicht am ende nicht brauchen.
Dazu ein paar 0.33ohm hochlastwiderstände und ein TRIAC. insg. ca 20..25€ an teile.

Wofür der TRIAC?
Yamaha nutzt ein interessantes Trafonetzteil, deren Trafo ist eigentlich unterdimensioniert und geht schon bei recht wenig spannung in die sättigung.
Der TRIAC regelt die leistung die durch den Trafo geht, damit am ende egal ob 200 oder 240v immer die gleiche spannung in den Elkos landen, und bei viel leistungsentnahme, regelt der hoch damits gleich bleibt.

Das ist der verfluchte teil mit dem wundersamen IG04080 IC.. Dieser schaltet durch sobald eingang 1 mehr spannung anliegen hat als eingang 2. Unobtanium und nachbauschaltungen gibts auch keine. Worst case wenn der verreckt.
Das Board schaltete bei mir nicht, trotz neuer SCR / TRIACS, ich vermutete daher ein kaputten IG04080, habs aber erstmal auf die seite gelegt.

auf dem Board und dem Hauptschalter tauschte ich alle RIFA's gegen WIMA's aus.. mit der ausnahme des großen X2 kondensators, der wieder von RIFA ist, aber hoffentlich diesmal in besserer qualität als die 80er jahre bomben.
Der Haupt-triac wurde vom vorbesitzer auch schon "erneuert".. aber gegen ein total unpassenden mit zu wenig leistung, ich habe ein BTA16 verpflanzt welcher eher zum original passt.

Bevor es an die Endstufe geht, erst noch das Frontpanel und die VU meter.
dort hatte jemand die Lämpchen ausgetauscht, natürlich alle kaputt weil falsche spannung.
Ich werde die gegen warmweiße LED's mit gleichrichter und glättung austauschen, damit diese etwas nachleuchten und nicht flackern.
Das hatte ich schonmal bei einem Marantz receiver gemacht, was täuschend echt wie Glühbirnen aussah.


Also gut, die Endstufe.
Die kaputten transistoren hatte ich entfernt und bestätigt dass beide kaputt sind, die Treibertransistoren waren zum glück alle noch heile.
Ich habe damits wieder symmetrisch ist alle 8 Leistungstransistoren gegen neue, austauschmodelle getauscht, da man die originalen von Sanken nicht mehr bezahlbar bekam.

Eine liste mit aller Transistoren (original : austausch) habe ich ebenfalls erstellt:

Code: Alles auswählen

SA1146 = SA1186
SC2706 = SC2581 
SA968 = SA968
SC2238 = SC2336
SA1145Y = SA1013
SC2705Y = SC2383
SC1509 =  SC2383
SA777 = 2N5401
SC2240 = SC2240

R168 R170 R169 R167  150R
4.7R R187..R190
Ok, nun zur linken seite.. wieso ist der Collector mit kurzschluss auf den Kühlkörper.. hat da jemand das glimmer-isolator pad vergessen? nein ist noch da, Transistor war vom Kühlkörper weg aber immernoch totaler kurzschluss.
Oben hatte ich erwähnt, dass jemand drinn rumgepfuscht hat.. So auch hier.. wer auch immer dachte B- an E (GND) anschließen zu müssen hat keine ahnung von Elektronik.
Das war schnell behoben und der kurzschluss war weg.

Nachdem ich alle Transistoren getauscht hatte, ging es an einen isolierten Test mit wenig power.
Die Protection lampe ging an, aber nicht aus... MMh DC Offset vielleicht? ich dreh mal an den Potis.. nix.
Nach etwas hin und her messen fand ich 2 Widerstände die durchgebrannt waren, nachdem diese ausgetauscht waren
und dem erneuten einschalten mit niedrigerer Spannung hörte man das "Klick", das "Klick" des "du bist fertig" moments.
Fix eine Audioquelle und lautsprecher ran, alles lief.
Selbst die relais, potis und schalter waren alle Kratzfrei.

Selbst das TRIAC board lief jetzt problemlos und das VU meter leuchtete zur musik, der Mysteriöse IC war also doch in ordnung. Woohoo, fertig.. naja fast.

Jetzt muss ich noch die beleuchtung gegen LED austauschen, den Offset, Bias, VU meter gain und das "Zero distortion circuit adjustment" einstellen..
Dazu verpasse ich dem teil noch ein IEC anschluss statt des fest verbauten Kabels.

Aber das größte problem bleibt. Das Gehäuse..
Ebenfalls unobtanium. Da was aus blech biegen oder ein Holzgehäuse fertigen wäre wohl die einzige option.

Es sei denn jemand hat ein altes gehäuse rumliegen dass in etwa passt.
Die maße wären ca 425..430mm breite, 325mm tiefe, 120mm höhe.
Wenn da jemand was rumliegen hat, würde ich es gerne abkaufen!
Dateianhänge
IMG_20200601_134842.jpg
IMG_20200601_134826.jpg
IMG_20200601_134817.jpg
IMG_20200601_134537.jpg
IMG_20200601_134454.jpg
IMG_20200601_122831.jpg
:wurst:

Benutzeravatar

Thread-Ersteller
gamerpaddy
Beiträge: 2369
Registriert: Mo 13. Aug 2012, 09:03
Spezialgebiet: Spezialgebiet
Schule/Uni/Arbeit: Schule/Uni/Arbeit
Wohnort: Mannheim
Hat sich bedankt: 22 Mal
Danksagung erhalten: 188 Mal
Kontaktdaten:

Re: Reparatur: Yamaha M-50 Endstufe

#2 Beitrag von gamerpaddy »

umrüstung auf LED fertig. diode -> elko -> vorwiderstand -> led, so hat man 0 flackern und ein nachleuchten wie bei glühlampen.
hätte wohl rote leds nehmen sollen, ich dachte da wären filter drinn weil die originallampen auch nur klare glühlampen waren.

Läuft, aber das teil zieht >200W im leerlauf und ca 400W wenn musik in zimmerlautstärke rauskommt, ich kann mich nicht erinnern ein class-a amp gekauft zu haben^^
mal nach dem justieren gucken, vielleicht ist auch nur der ruhestrom viel zu hoch. verzerrt klingt aber nix.

Und die sicherung flog einmal beim einstecken als der power-schalter noch auf AN war, nervig sowas.

als deckel hab ich mir jetzt alu-lochblech geholt, wird gebogen und schwarz angemalt. kommt die tage.
Dateianhänge
IMG_20200605_143539.jpg
:wurst:

Benutzeravatar

stoppi
Beiträge: 1402
Registriert: Mo 29. Mär 2010, 21:39
Danksagung erhalten: 263 Mal
Kontaktdaten:

Re: Reparatur: Yamaha M-50 Endstufe

#3 Beitrag von stoppi »

Wirklich ganz tolle Sache, wie du die reparaturbedürftigen Teile wieder flott bekommst. Ich wäre da ja heillos überfordert herauszufinden, was nun auszutauschen ist. Obwohl ich eigentlich auch immer versuche, Teile/Geräte so lange wie nur möglich (inkl. Reparaturen) zu verwenden. Finde die moderne Wegwerfgesellschaft schrecklich...

Benutzeravatar

kilovolt
Beiträge: 13061
Registriert: So 25. Feb 2007, 09:50
Hat sich bedankt: 457 Mal
Danksagung erhalten: 286 Mal
Kontaktdaten:

Re: Reparatur: Yamaha M-50 Endstufe

#4 Beitrag von kilovolt »

Hallo gamerpaddy

ich finde es auch bemerkenswert, wieviel Mühe Du in diese Audioreparaturen investierst :awesome: Wirklich tolle Arbeit, die zum einen nicht jeder könnte und zum anderen nicht jeder auf sich nehmen würde. Cool!

Beste Grüsse
kilovolt
Alle Angaben meinerseits ohne Gewähr! Ich lehne jegliche Haftung für Personen- und/oder Sachschäden ab. Jeder ist für seine Sicherheit selber verantwortlich.

http://www.kilovolt.ch

Benutzeravatar

Thread-Ersteller
gamerpaddy
Beiträge: 2369
Registriert: Mo 13. Aug 2012, 09:03
Spezialgebiet: Spezialgebiet
Schule/Uni/Arbeit: Schule/Uni/Arbeit
Wohnort: Mannheim
Hat sich bedankt: 22 Mal
Danksagung erhalten: 188 Mal
Kontaktdaten:

Re: Reparatur: Yamaha M-50 Endstufe

#5 Beitrag von gamerpaddy »

achwas, das ist einfacher als man denkt.
Das könnte jeder mit etwas equipment der schonmal sich mit elektronik beschäftigt hat, ohne jetzt die theorie und formeln dahinter zu kennen.
Ich kann mir fast keine formel merken.. selbst das Ohmsche gesetz muss ich ständig wieder raussuchen weil ich vergessen habe wo jetzt geteilt und multipliziert wird :D Bisher habe ich aber noch nix davon bei reparaturen anwenden müssen.

Es sieht nur kompliziert aus, darum wird es immer gleich weggeworfen.
Stattdessen kann man sich daran versuchen und rumprobieren, mehr als kaputt machen kann man eh nicht, im schlimmsten fall verliert man 5..10€ an neuen bauteilen aber lernt dazu. Wenn's doch klappt, hat man wieder etwas an dem man sich erfreuen kann.

Ich musste bisher nur selten die schaltung länger analysieren um zu verstehen wieso was kaputt ist.
Darum nehme ich auch nur die alten Geräte, die sind noch einfach aufgebaut ohne digitalkram bei dem die firmware vielleicht korrupt ist....

Bei vielen neuen Geräten kommt man auch das Service-handbuch, sehr detailiert teilweise (siehe pioneer sc37.. sehr detailiert und übersichtlich aber extrem komplex) aber meist die zeit nicht wert.


Als erstes gilt: Lötstellen prüfen, verkabelung anschauen ob jemand drann rumgespielt hat. Schauen ob was fehlt oder lose ist.
Die alten Lötstellen brechen gerne, an bauteilen mit masse oder hebelwirkung (zb. großen widerständen, lautsprecher terminals, relais) wackeln, und nach rissen schauen, die sieht kaum.
Präventiv kann man alle größeren lötstellen erneuern, dauert nur ein paar minuten und man hat auf lange zeit ruhe.

Dann Spannungen prüfen. Versorgungsleitungen zur Endstufe kappen (wenn möglich) falls diese Kurzgeschlossen ist. Kann man mit einem Durchgangsprüfer ja vorher testen.
Wenn im Datenblatt keine Spannungen stehen, kann man sich ja grob an den Elkos orientieren.
Wenn keine Spannung an den Versorgungsleitungen ankommt, geht man Rückwärts bis man bei der Steckdose ankommt :D
Da lohnt sich ein Getrennter-stelltrafo oder ein DBT (dim bulb tester, glühlampe in reihe für stromlimit) damit man nix in die luft jagt sollte doch mehr kaputt sein.
Wenn RIFA's Typ X oder typ Y drinn sind, raus damit. Meist werfen leute Geräte weg weil die geknallt haben und rauch raus kommt.. Das sind genau die verantwortlichen bauteile dafür.

Dann rückwärts die Endstufe prüfen (Lautsprecher ausgang zum Pre-amp eingang)
Ein Kanal tot? Endstufentransistoren raus, mit so einem billigen bauteil-tester oder durchgangsprüfer / diodentester prüfen.
Und so nur noch der Schaltung folgen und jedes bauteil grob testen. ggf. von A nach B den durchgang prüfen falls Leiterbahnen gebrochen sind oder durchkontaktierungen kein kontakt mehr haben.

Wenn man unsicher ist ob ein Bauteil kaputt ist man aber es nicht auslöten will kann man sich das gleiche auf der anderen Endstufenseite zum vergleich nehmen, meist brennt eh nur eine Seite durch.
Wenn man verbrannte bauteile sieht, natürlich diese erneuern und in der Schaltung schauen wo diese angeschlossen waren und auch dort die bauteile prüfen.

Alles soweit fertig, also langsam einschalten. ggf. riechen / schauen ob was heiß wird.
Wenn die Protection schaltung klickt, hat man das größte überstanden. Dann sinds meist nur noch kleinigkeiten, justierung nach herstellervorgaben, beleuchtung usw.
Dann noch Musik an eingang, Lautsprecher an den ausgang.
Mit dem Gehör findet man zusätzlich fehler die so garnicht sichtbar sind, zb. ein basis-widerstand auf einem kanal der erst ab einem stärkeren signal leitend wird. Klingt dann verzerrt und sieht auf dem Oszi abgehackt aus, als wäre die Bias falsch eingestellt, aber nur bei einer halbwelle statt beiden.

Selbst das schlachtfeld im Thule, oder die angebrannten NAD's liefen genau so ab.
:wurst:

Benutzeravatar

Paul
Admin
Beiträge: 3379
Registriert: So 7. Aug 2005, 14:34
Schule/Uni/Arbeit: HW/SW-Entwickler
Wohnort: Braunschweig
Hat sich bedankt: 398 Mal
Danksagung erhalten: 134 Mal
Kontaktdaten:

Re: Reparatur: Yamaha M-50 Endstufe

#6 Beitrag von Paul »

Tolle Zusammenfassung, Paddy! :awesome:
gamerpaddy hat geschrieben:
Mo 8. Jun 2020, 13:13
Wenn RIFA's Typ X oder typ Y drinn sind, raus damit. Meist werfen leute Geräte weg weil die geknallt haben und rauch raus kommt.. Das sind genau die verantwortlichen bauteile dafür.
Hehe! Bei mir sinds alte Tantal-Elkos, die ich immer sofort im Verdacht habe. Diese kleinen Scheisser machen nach 30 Jahren gerne mal nen Kurzschluss.
So hab ich schon einen Spektrumanalysator wieder hingekommen, Versorgungsleitungen von Board zu Board bis zum Kurzschluss zurückverfolgt.
“With great power come great heat sinks.”

Benutzeravatar

Bastl_r
Beiträge: 725
Registriert: So 21. Mär 2010, 04:32
Hat sich bedankt: 21 Mal
Danksagung erhalten: 22 Mal

Re: Reparatur: Yamaha M-50 Endstufe

#7 Beitrag von Bastl_r »

Paul hat geschrieben:
Mo 8. Jun 2020, 20:06
So hab ich schon einen Spektrumanalysator wieder hingekommen, Versorgungsleitungen von Board zu Board bis zum Kurzschluss zurückverfolgt.
Ja, mit dem geeigneten Messgerät das auch im mV Bereich noch ordentlich auflöst lässt sich schön der Spannungsabfall an den Leiterbahnen bis zu den Elkos nachverfolgen. Hatte ich letztens in Verbindung mit "normalen" Elkos und einem nur schwachen Spannungsregler.

bastl_r

Benutzeravatar

Thread-Ersteller
gamerpaddy
Beiträge: 2369
Registriert: Mo 13. Aug 2012, 09:03
Spezialgebiet: Spezialgebiet
Schule/Uni/Arbeit: Schule/Uni/Arbeit
Wohnort: Mannheim
Hat sich bedankt: 22 Mal
Danksagung erhalten: 188 Mal
Kontaktdaten:

Re: Reparatur: Yamaha M-50 Endstufe

#8 Beitrag von gamerpaddy »

Das Gehäuse ist fertig, es besteht aus 1mm Alu-lochblech. Lies sich gut schneiden und mit einem Hammer formen.
Nachdem ich den Bias, DC offset und B- Voltage Adjust gemacht habe zieht die Endstufe auch wieder die korrekte leistung im leerlauf.
B- war auf -75V.. die elkos sind aber nur 63V, gut dass da nix kaputt ging.

IMG_20200612_185056.jpg
IMG_20200612_185011.jpg
Sieht brauchbar aus, ist stabil genug um zeug draufstellen zu können und klingt auch gut. erledigt.

edit: hab jetzt doch ne kaltgeräte buchse rein. diese billigen akkuschrauber nibbler / blechschneider fressen sich problemlos durch das stahlblech. macht nur ne riesen sauerei.
:wurst:

Antworten