avrdude Fehlermeldung: libusb0.dll

Programmierung und Hardwaredesign mit Arduino, AVR, PIC und Konsorten.

Moderatoren: MaxZ, ebastler, SeriousD

Antworten
Benutzeravatar

Thread-Ersteller
gottlob100
Beiträge: 54
Registriert: Fr 6. Sep 2013, 10:55
Schule/Uni/Arbeit: Schule

avrdude Fehlermeldung: libusb0.dll

Beitrag von gottlob100 »

Hallo

Ich habe den avr-isp-stick von ehajo gekauft und erfolgreich aufgebaut.
Dann habe ich avrdude heruntergeladen und wenn ich das Programm
ausführen will kommt immer die Fehlermeldung: libusb0.dll fehlt. Ich kann das Programm also nicht ausführen. Was kann man dagegen tun?
Mein Betriebssystem ist Windows 8 und ich habe auch den Treiber schon
heruntergeladen.

danke im voraus
Benutzeravatar

gamerpaddy
Beiträge: 2742
Registriert: Mo 13. Aug 2012, 09:03
Spezialgebiet: Spezialgebiet
Schule/Uni/Arbeit: Schule/Uni/Arbeit
Wohnort: Mannheim
Hat sich bedankt: 38 Mal
Danksagung erhalten: 329 Mal
Kontaktdaten:

Re: avrdude Fehlermeldung: libusb0.dll

Beitrag von gamerpaddy »

Na die libusb0.dll nachinstallieren
http://www.pinguino.cc/download/doc/libusb-windows7.pdf
http://sourceforge.net/p/libusb-win32/wiki/Home/

Sollte auch unter windows 8 funktionieren, falls nicht, setz eine VirtualBox mit Windows 7 auf.
:wurst:
Benutzeravatar

MalteP
Beiträge: 788
Registriert: Fr 20. Jul 2007, 12:35
Spezialgebiet: Analog, Digital und µC Technik
Wohnort: Uelzen
Danksagung erhalten: 1 Mal
Kontaktdaten:

Re: avrdude Fehlermeldung: libusb0.dll

Beitrag von MalteP »

gamerpaddy hat geschrieben:Sollte auch unter windows 8 funktionieren, falls nicht, setz eine VirtualBox mit Windows 7 auf.
Nope, der setzt eine Signatur vorraus. Sollte aber im Gerätemanager als "Kann nicht gestartet werden" auftauchen.

Erzeuge dir mit diesem Tool einen Treiber:
http://zadig.akeo.ie/

Funzt dann auch unter 8/8.1/10 da entsprechend signiert.
Bild
Antworten