Induction Heater - mittelgroß - 12-50V Input

Sonstige Basteleien aller Art kommen hier hinein.

Moderatoren: ebastler, SeriousD, MaxZ

Nachricht
Autor
Benutzeravatar

Thunderbolt
Beiträge: 2649
Registriert: Fr 7. Apr 2006, 14:05
Spezialgebiet: Physik,Elektronik,Blender
Schule/Uni/Arbeit: EIT h_da
Wohnort: 65366 Geisenheim (Hessen)
Hat sich bedankt: 1 Mal
Danksagung erhalten: 22 Mal
Kontaktdaten:

Re: Induction Heater - mittelgroß - 12-50V Input

#16 Beitrag von Thunderbolt »

Hallo Multi-Kv,

Hier gibts noch ein paar

https://markobakula.wordpress.com/wirel ... onstrator/ anmerkungen zur Schaltung.

Im Anhang hab ich zwei PDFs angehängt, in denen ich im Rahmen eines Semesterprojekts näher auf die Verwendung des Royer-Wandlers zur Drahtlosen Energieübertragung eingegangen bin.

Speziell findest du im PDF "Funktionsweise" Details zum Anschwingvorgang
Dateianhänge
Hardware.pdf
(15.39 MiB) 11-mal heruntergeladen
Funktionsweise.pdf
(174.19 KiB) 11-mal heruntergeladen

Benutzeravatar

Thread-Ersteller
Multi-kv
Beiträge: 2819
Registriert: Di 30. Jun 2015, 20:45
Spezialgebiet: Informatik
Wohnort: Nähe Heidelberg
Hat sich bedankt: 191 Mal
Danksagung erhalten: 125 Mal

Re: Induction Heater - mittelgroß - 12-50V Input

#17 Beitrag von Multi-kv »

Vielen Dank, Thunderbolt - schaue ich mir noch genau an :-)

stoppi: was stimmt da nicht bei L3? L2 und L3 sind gleich mit identischen Werten.

Benutzeravatar

stoppi
Beiträge: 1374
Registriert: Mo 29. Mär 2010, 21:39
Danksagung erhalten: 256 Mal
Kontaktdaten:

Re: Induction Heater - mittelgroß - 12-50V Input

#18 Beitrag von stoppi »

Beide drosseln müssen mit Plus verbunden sein und gehen dann auf jeweils eine Seite der workcoil...

Benutzeravatar

Thread-Ersteller
Multi-kv
Beiträge: 2819
Registriert: Di 30. Jun 2015, 20:45
Spezialgebiet: Informatik
Wohnort: Nähe Heidelberg
Hat sich bedankt: 191 Mal
Danksagung erhalten: 125 Mal

Re: Induction Heater - mittelgroß - 12-50V Input

#19 Beitrag von Multi-kv »

:oops: Hast Recht, stoppi, war mir noch gar nicht aufgefallen. Schwingt trotzdem an... ;-)

Werde ich ändern und wieder berichten :-)

Hier die geänderte Schaltung und die Anschwingprobleme sind weg:
Royer02_10us_50uH.JPG
Anstiegszeit 10 us, Drosseln: 50 uH. Selbst bei einer Anstiegsflanke mit 100 us gab es noch keine Probleme :-)
Danke stoppi! ;)

Benutzeravatar

Count-Doku
Beiträge: 428
Registriert: Mi 26. Jun 2013, 15:44
Schule/Uni/Arbeit: Informatikstudent (TUBS)
Hat sich bedankt: 29 Mal
Danksagung erhalten: 55 Mal

Re: Induction Heater - mittelgroß - 12-50V Input

#20 Beitrag von Count-Doku »

Die Anschwingproblematik gibt es aber in der Realität trotzdem noch. Es kann den ungünstigen Fall geben, dass beide Halbleiter nahezu gleich schnell beginnen zu leiten. Dann bleiben beide im linearen Bereich, und das Gate balanciert im Prinzip zwischen der durch die Widerstände gegebenen Vorspannung und dem Strom, der durch den jeweils anderen Transistor "abgesaugt" wird. Letzlich hast du dann 2 Spannungsteiler aus dem Vorwiderstand und dem Widerstand des MOSFET. Gleichzeitig fließt ein hoher Strom durch beide MOSFETs je von Drain nach Source (die Drosseln sind im Gleichstromfall einfach weg) -> Kurzschluss über der Versorgung mit dem Widerstand der MOSFETs. Das kann (je nach Mosfet) schnell zerstörend werden.

Benutzeravatar

Thread-Ersteller
Multi-kv
Beiträge: 2819
Registriert: Di 30. Jun 2015, 20:45
Spezialgebiet: Informatik
Wohnort: Nähe Heidelberg
Hat sich bedankt: 191 Mal
Danksagung erhalten: 125 Mal

Re: Induction Heater - mittelgroß - 12-50V Input

#21 Beitrag von Multi-kv »

Könnte man diese Problematik nicht mit einem kleinen "Ungleichgewicht" in den beiden Kreisen beheben, z.B. eine kleine Änderung im Vorwiderstand oder eine leicht andere Z-Diode in einem Zweig? Jeder Mosfet ist ja trotz Serienfertigung individuell leicht unterschiedlich und schaltet minimal schneller oder langsamer als der andere - aber es leuchtet ein, es kann zu solchen undefinierten Zuständen kommen.

Was nicht so gut kommt sind kleine Ungleichgewichte in den beiden Drosseln: schon eine Abweichung um 10% vom Wert der anderen kann zu ziemlichen "Herzrythmusstörungen" führen und zur 11-fachen Eingangsspannung über den Mosfets! :
Royer02_10us_50uH+45uH.JPG

Benutzeravatar

Thread-Ersteller
Multi-kv
Beiträge: 2819
Registriert: Di 30. Jun 2015, 20:45
Spezialgebiet: Informatik
Wohnort: Nähe Heidelberg
Hat sich bedankt: 191 Mal
Danksagung erhalten: 125 Mal

Re: Induction Heater - mittelgroß - 12-50V Input

#22 Beitrag von Multi-kv »

Noch eine kleine Ergänzung: diese "Fehlzündungen" in der Simulation können natürlich auch von Unzulänglichkeiten der Simulation herrühren. Hatte jetzt einige Konstellationen, wo die Spannung über den Mosfets kurzzeitig bis zum 15-fachen der Eingangsspannung betrug. Habe ich die Simulation komplett neugestartet, waren die Ergebnisse schon wieder etwas anders. Offenbar läuft auch hier die Schwingung nicht immer ganz stabil ab :-)

Habe nochmal einige Simulation zur "Verlustleistung" der Workcoil im Vergleich zur Eingangsleistung gemacht. Hier der Einschwingvorgang der ersten 0,5 ms. Im Diagramm sind eingetragen: Spannung und Strom über der Spule sowie deren Produkt:
Royer02_10us_96uH_LeistungCoil.JPG
und hier die Eingangsleistung:
Royer02_10us_96uH_Leistung_Input.JPG
Im eingeschwungenen Betrieb (Messung nach 4,5 ms) liegt die Eingangsleistung bei ca. 472 W und die Leistung an der workcoil bei knapp 192 W.
Das wäre ein recht schlechter Wirkungsgrad - bin mir aber nicht ganz sicher, was ich da wirklich "gemessen" habe... :?
Eigentlich müßte es die Wirkleistung sein, das LTspice ja immer die Momentanwerte in der Rechnung berücksichtigt.

Benutzeravatar

Thread-Ersteller
Multi-kv
Beiträge: 2819
Registriert: Di 30. Jun 2015, 20:45
Spezialgebiet: Informatik
Wohnort: Nähe Heidelberg
Hat sich bedankt: 191 Mal
Danksagung erhalten: 125 Mal

Re: Induction Heater - mittelgroß - 12-50V Input

#23 Beitrag von Multi-kv »

Auch wenn es langsam nervt, hier nochmal die Simulation mit MicroCaps - gleiche Schaltung, gleiche Werte:
Royer2_MC_80u.JPG
Im Test fiel auf: die Simulation läuft etwas stabiler als in LTspice auch bei starker Variation der Induktivitäten der beiden Drosseln oder der Anstiegsflanke der Eingangsspannung.
Insgesamt aber sehr ähnliche Ergebnisse - was aufgrund des gleichen zugrundeliegenden Simulationsalgrorithmus (Spice) ja auch nicht anders zu erwarten war :-)

Benutzeravatar

Thread-Ersteller
Multi-kv
Beiträge: 2819
Registriert: Di 30. Jun 2015, 20:45
Spezialgebiet: Informatik
Wohnort: Nähe Heidelberg
Hat sich bedankt: 191 Mal
Danksagung erhalten: 125 Mal

Re: Induction Heater - mittelgroß - 12-50V Input

#24 Beitrag von Multi-kv »

Guten Morgen Bastelfreunde,

nach so viel Theorie geht es nun endlich praktisch weiter, da die fehlenden Bauteile eingetroffen sind :-)

Die workcoil und den Schwingkreis hatte ich schon vorher fertig gemacht, da ich die Teile da hatte. Die Spule ist aus 4mm CuL aus einem alten Schweißtrafo: 10 Windungen, knapp 70mm DM.
Für die Schwingkreiskondensatoren hatte ich 2 verschiedene WIMA MKP da: MKP10 mit 1uF bei 1600V oder Snubber MKP 1uF bei 2000V. Eigentlich sollten die 1600 V locker reichen aber da im Schwingkreis hohe Ströme fließen gefielen mir die deutlich dickeren Flachanschlüsse mit Schraubloch wesentlich besser. Davon ließen sich 4 Stk. schön kombinieren, so dass ich ohne Löten auf 4uF komme:
IH1_01kl.jpg
Die Kontakte der Wima-Caps sind über 1x16mm Kupferflachband miteinander verbunden und dann über 16mm2 Kabel an die workcoil geklemmt. Die Verbindung ist zwar etwas länglich geworden, aber ich wollte flexibel bleiben und die workcoil leicht auswechseln können. Die Anschlüßdrähte der workcoil könnte ich aber noch etwas kürzen.

Als dann die Bauteile eintrafen habe ich den Royerconverter aufgebaut:
IH1_02kl.jpg
Die Kühlkörper für die Mosfets (IRFP4768 - 250V, 90 bzw. 66 A bei 20 bzw. 100 oC) sind evtl. etwas klein, aber ich dachte bei der Leistungsklasse sollte das keine Probleme machen :roll:
Die Drossel habe ich selber gewickelt aus Ferrit(?)-Ringkernen und 3 x 1mm Cul mit je 8 Windungen parallel, so dass ich hier auf 2,25 mm2 komme. Lt. Simulation fließen hier bei 40V Eingang ca. 12 - 16 A RMS - das sollte vom Querschnitt her reichen. Beim Kernmaterial und was die Sättigung angeht bin ich mir aber nicht 100%ig sicher. Für den Kern komme ich nach Messungen auf einen AL von 1500 nH. Bei 8 Windungen liege ich bei knapp 100 uH.
Da ich keine 5W Z-Dioden für 12V hatte, habe ich meinen 1,3W Dioden noch ein kleines Kühlblech verpasst (auf der braunen Lochrasterplatte rechts):
IH1_02a_Z-Dioden.jpg
IH1_02a_Z-Dioden.jpg (113.97 KiB) 213 mal betrachtet
Das erste Einschalten ist immer recht spannend und ich war sehr froh, dass es auf Anhieb funktionierte :-)
Als Speisung habe ich erstmal mein altes Eigenbau-NT aus Variac + nachgeschaltetem RK-Trafo + Brücken-GLR + 64 mF-Elko verwendet. Hier habe ich bis zu 30VDC bei bis zu ca. 25 A zur Verfügung - das sollte für Tests reichen. Habe das Teil auf 18V aufgedreht und einfach eingesteckt: Leerlaufstrom ca. 3,1 A - alles sieht gut aus.
Ein Stück 10mm Moniereisen in die Spule gesteckt und der Eingangsstrom steigt auf ca. 10 A.
Dann langsam hochgedreht und verschiedene Messungen gemacht:
IH1_03kl.jpg
oben sind die Gatesignale im unbelasteten und belasteten Zustand zu sehen. Das 2. Bild ist etwas unscharf - hatte vergessen die "Hold"-Taste zu drücken.
Dann seht ihr die Spannung an der workcoil und an jeweils einem Gate, tlw. unbelastet, tlw. belastet.
Es fällt auf, dass die Gate-Signale nicht ganz gleichartig sind, tlw. sind Einschwinger zu sehen, vor allem im unbelasteten Zustand.
Leider werden die Mosfets bei Belastung doch schnell heiß: bis 10A Eingangsstrom ist wohl gerade noch dauerhaft möglich, 15 A ist ohne aktive Kühlung aber schon grenzwertig. Nach ca. 30 sec. kann man die KK nicht mehr mit der Hand länger anfassen - da hätte ich deutlich mehr erwartet :roll:

Habe dann die Mosfets mal einer genaueren Prüfung unterzogen und bin zu dem Schluß gekommen, dass ich da wohl mal wieder auf China-fake hereingefallen bin.
Der Rdson liegt ca. 4-5 mal höher als er nach Datenblatt soll (sollte eigentlich bei max. 17,5 mR liegen) und die Input Capacity liegt nur ca. bei der Hälfte des Werte vom datasheet (sollte 10,8 nF sein). Obwohl ich die Werte mit meinem Equipment nicht exakt messen kann, weisen beide Werte zusammen auf nachgemachte fakes hin (kleinerer die, weniger interne Mosfets).
Bei einem Id von 10 A und einem Rdson von 18 mR dürften die internen Verluste bei max. 1,8 W liegen - die sollte der KK ganz locker ohne Lüftung abführen. Bei 15 A wären wir bei max. 4 W -
das sollte auch noch kein Problem sein. Tatsächlich sind es wohl eher 15-20W - was dann die Wärmeentwicklung erklärt.

Wieder billig aber umsonst gekauft! :facepalm:

Vermtlich wäre ich mit den eigentlich "schlechteren" aber echten IRFP250N hier sogar besser gefahren...

Welche Mosfets habt ihr hier verbaut und welche Erfahrungen habt ihr mit der Verlustwärme? Sind meine KK deutlich zu klein und brauchen aktive Kühlung?
Werde nochmal ein paar Lüfter vorsehen und weitere Tests machen - aber ich denke ich komme um eine neue Order ordentlicher Mosfets nicht herum :shock:

Immerhin bekomme ich mein Moniereisen zu leichter Rotglut - dann muß ich aber schnell wieder abschalten.

Leider werden auch die Drosseln bei 15A schon recht warm - das wäre das nächste schwache Glied in der Kette. Denke nicht, das es am Cul liegt mit immerhin 2,25 mm2 sondern eher an der Sättigung der Kerne - was meint ihr? Brauche ich hier ein anderes Kernmaterial?

Erfreulicherweise bleiben die Wima MKP Caps absolut kalt :-)
Die workcoil wird bei Belastung in 1 min. so heiß, dass man sie nicht mehr anfassen kann, aber der Lack hat noch nicht gekokelt. Das war hier auch nicht anders zu erwarten und ist sicher normal. Für größere Leistungen braucht man dann ja eh eine Wasserkühlung der Coil.
Werde mal schauen, dass ich noch Original-Mosfets bekomme und evtl. je 2 Stück parallel schalten.

Benutzeravatar

Bastl_r
Beiträge: 696
Registriert: So 21. Mär 2010, 04:32
Hat sich bedankt: 17 Mal
Danksagung erhalten: 22 Mal

Re: Induction Heater - mittelgroß - 12-50V Input

#25 Beitrag von Bastl_r »

Hey, Klasse Aufbau "mit dem was man so zur Verfügung hat". :awesome:
Finde ich immer wieder Spitze wie Ihr das macht.

Ich mache dir hier ein Angebot: Hast Du Interesse an Mosfets in SOT227 Gehäuse?
Typ weis ich grad nicht aber so 40A und zwischen 400 und 600V dürftens schon sein.
Kannst gegen Porto haben. Ich mache die nächste Zeit eh nichts damit.

bastl_r

Benutzeravatar

Thread-Ersteller
Multi-kv
Beiträge: 2819
Registriert: Di 30. Jun 2015, 20:45
Spezialgebiet: Informatik
Wohnort: Nähe Heidelberg
Hat sich bedankt: 191 Mal
Danksagung erhalten: 125 Mal

Re: Induction Heater - mittelgroß - 12-50V Input

#26 Beitrag von Multi-kv »

Danke Bastl_r - auch für Dein nettes Angebot :-)
Habe jetzt gerade bei LCSC nochmal die Original-Mosfets geordert.
Bin auch nicht so der Freund von SMD-Bauteilen - sind mir einfach viel zu klein für meine inzwischen schlechten Augen und meine groben Lötkünste ;-)
Greife eigentlich nur auf SMD zurück, wenn es gar nicht anders geht und es keine geeigneten THT-Teile gibt.
Aber nur mal interessehalber: welche Mosfets wären das genau?

400V bei 40A und das in SMD finde ich schon erstaunlich :shock:

Habe mir auch gleich neue superfast Dioden RHRP3060 geordert - die bisherigen China-Teile könnten auch fake sein und evtl. für schlechte Schaltzeiten bei den Mosfets und deren zusätzliche Erwärmung sorgen. Je kürzer die Schaltzeiten, desto geringer ja die Verluste. Muß mal gucken, ob ich die Dioden irgendwie testen kann, sollen eine recovery time von 45ns haben.

Benutzeravatar

McGaiver
Beiträge: 104
Registriert: Mo 13. Dez 2010, 01:27
Danksagung erhalten: 15 Mal
Kontaktdaten:

Re: Induction Heater - mittelgroß - 12-50V Input

#27 Beitrag von McGaiver »

Hallo.

Wie kommst du darauf das die Fet´s fakes sind?
Aus welcher Quelle hast du die geordert?

Wie hast du die Gatekapazität und Rdson gemessen?
Ersteres geht nicht mit einem DMM. Rdson ist auch nicht so einfach. Im DS inst der Rdson vom Die angegeben. Die Anschlussbeine und das bonding ist da nich nicht mit dabei.

Bei einem Id von 10 A und einem Rdson von 18 mR dürften die internen Verluste bei max. 1,8 W liegen - die sollte der KK ganz locker ohne Lüftung abführen. Bei 15 A wären wir bei max. 4 W -
das sollte auch noch kein Problem sein. Tatsächlich sind es wohl eher 15-20W - was dann die Wärmeentwicklung erklärt.
Hast du diese Werte mit DC (20V am Gate) ermittelt?


mfg
Chris
BRZRRZZRZRTRZRRZRZTRTRT.... xD was war das denn ^^

Benutzeravatar

Thread-Ersteller
Multi-kv
Beiträge: 2819
Registriert: Di 30. Jun 2015, 20:45
Spezialgebiet: Informatik
Wohnort: Nähe Heidelberg
Hat sich bedankt: 191 Mal
Danksagung erhalten: 125 Mal

Re: Induction Heater - mittelgroß - 12-50V Input

#28 Beitrag von Multi-kv »

Hallo Chris,

die Mosfets hatte ich über ebay aus China gekauft - leider zu billig. Die sind mit sehr großer Sicherheit counterfeits - hatte 5 Stk. für etwa 8 Eur gekauft. Bei Conrad kostet einer über 6 Eur.
Bei LSCW (Elektronikgroßhandel aus China) kostet einer noch ca. 3,50 Eur.
Den Rdson habe ich unter Impulsbelastung mit ca. 40 A gemessen, lt. datasheet bei 56 A mit sehr kurzen Impulsen. Über die D-S Strecke habe ich dabei den Spannungsabfall mit einem Scopemeter gemessen und daraus den Rdson. Mir ist klar das das recht ungenau ist, daber Werte die 4..5 mal so hoch sind, scheinen mir zu viel. Der Rdson wird lt. datasheet bei Vgs=10 V gemessen, ich habe bei 12V gemessen. Die Gatekapazität habe ich mit einem elektron. Bauteiletester, so ein Multifunktionstester, ermittelt. Auch diese Werte sind natürlich nur sehr grob und 10-20% Abweichungen können durchaus sein. Aber nahezu 50% Abweichung wäre recht viel.
Es ist leider nicht unüblich (und fast schon die Regel), das günstige Elektronikbauteile aus ebay-China nachgemachte Teile sind, die zwar das Original versuchen zu imitieren, aber häufig 2, 3 oder 4 mal schlechtere Werte haben.

Habe mir inzwischen nochmal die Gatesignale im unbelasteten und belasteten Zustand angesehen. Die Anstiegs- und Abstiegsflanken werden bei Belastung deutlich schlechter. Seht selbst:
Gate_Flanken_unbelastet_bei_16V_kl.jpg
Gatesignale_unbelastet_und_belastet.jpg
Schon im unbelasteten Zustand liegen die An- und Abstiegszeiten bei ca. 2 us, im belasteten Zustand steigt die Anstiegszeit auf ca. 4, die Abstiegszeit auf ca. 7 us. Das sind dann bei 40 kHz Schaltfrequenz 40000 * (4+7 us) = 440 ms mehr oder weniger im Linearbetrieb pro sec - nicht gut! Ich vermute stark, dass liegt auch an den "fake" RHRP3060 (auch aus ebay-China) :facepalm:
Wenn ich mir die turn-on und rise time bzw. turn-off und fall-time Werte aus dem datasheet für die Mosfets ansehe, sollten ca. 200ns auf beiden Flanken möglich sein. Die Dioden recovery time sollte bei 45 ns liegen - tut sie vermutlich nicht. Dazu kommen natürlich "Störungen" durch Streukapazitäten und Induktivitäten - aber Schaltzeiten unter 1 us sollten doch möglich sein?
Oder liege ich da völlig falsch?

Habt ihr mal ähnliche Messungen an euren Induction Heatern gemacht?

Benutzeravatar

Thunderbolt
Beiträge: 2649
Registriert: Fr 7. Apr 2006, 14:05
Spezialgebiet: Physik,Elektronik,Blender
Schule/Uni/Arbeit: EIT h_da
Wohnort: 65366 Geisenheim (Hessen)
Hat sich bedankt: 1 Mal
Danksagung erhalten: 22 Mal
Kontaktdaten:

Re: Induction Heater - mittelgroß - 12-50V Input

#29 Beitrag von Thunderbolt »

Multi-kv hat geschrieben:
Mo 18. Mai 2020, 09:25
Bin auch nicht so der Freund von SMD-Bauteilen - sind mir einfach viel zu klein für meine inzwischen schlechten Augen und meine groben Lötkünste ;-)
Greife eigentlich nur auf SMD zurück, wenn es gar nicht anders geht und es keine geeigneten THT-Teile gibt.
Das gehäuse heißt zwar SOT, sind aber tatsächlich mini-bricks mit schraubanschlüssen ;)
ich war auch etwas irritiert wegen dem "SOT" im namen

Benutzeravatar

McGaiver
Beiträge: 104
Registriert: Mo 13. Dez 2010, 01:27
Danksagung erhalten: 15 Mal
Kontaktdaten:

Re: Induction Heater - mittelgroß - 12-50V Input

#30 Beitrag von McGaiver »

Messe mal bitte den Mosfet mit 10V Gatespannung und 10A Drainstrom (direkt da messen wo D und S in die Vergussmasse gehen) und sinnigerweise bei DC durchführen mit ausreichend genauem Multimeter.
solch Peakmessungen können sehr schnell zu massiven messfehlern führen.

Das Gatesignal sieht auf jeden fall sehr ungut aus. Kein Wunder das die Mosfets dann so heizen im Linearbetrieb.
BRZRRZZRZRTRZRRZRZTRTRT.... xD was war das denn ^^

Antworten